We have successfully restored the majority of the missing Ad Spend data and resolved the intermittent issue with missing tracker names in reports. Our team is actively working to restore the remaining Ad Spend data.
Posted Jun 05, 2026 - 07:13 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 05, 2026 - 06:30 UTC
Investigating
We are currently investigating several reporting issues. Ad Spend data is missing for all clients using cron schedules, affecting part of yesterday's data and today's data, while clients using custom schedules via the Scheduling Service appear to be unaffected. We are also observing intermittent cases of missing tracker names in reports.
Posted Jun 05, 2026 - 05:05 UTC
This incident affected: Report Service and Ad Spend Service.