Degraded performance dashboard
Incident Report for
Adjust
Resolved
The issue has been resolved, all services are fully operational.
Posted
Sep
22
,
2025
-
13:30
UTC
Investigating
We are currently experiencing degraded performance for our dashboard. The engineering team is actively working on resolving the issue.
Posted
Sep
22
,
2025
-
13:00
UTC
This incident affected: Dashboard.
×
Subscribe to Incident
Subscribe to updates for
Degraded performance dashboard
via . You'll receive .