Adjust Service Outage - Monitoring

Incident Report for Adjust

Resolved

This incident has been resolved.
Posted May 26, 2025 - 08:17 UTC

Update

The deployment of mitigation measures has been completed, and service availability is fully operational. We are continuing to monitor the situation closely.
Posted May 24, 2025 - 17:00 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 24, 2025 - 11:43 UTC

Update

The issue has been identified and a fix is being implemented.
Posted May 24, 2025 - 07:25 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted May 24, 2025 - 06:05 UTC

Update

We are continuing to monitor for any further issues.
Posted May 23, 2025 - 18:00 UTC

Update

Permanent fix is in place, and indications are that services are fully operational. We are continuing to monitor the situation.
Posted May 23, 2025 - 14:41 UTC

Monitoring

We're continuing to monitor and improve availability
Posted May 23, 2025 - 12:30 UTC

Update

We've deployed initial protection measures, some endpoints still exist in a degraded state and we are working towards a permanent fix
Posted May 23, 2025 - 11:35 UTC

Update

We are continuing to work on a fix for this issue.
Posted May 23, 2025 - 10:58 UTC

Identified

Adjust is currently experiencing a service outage. The issue has been identified as a DDoS attack and a fix is being implemented. While the issue is present, a significant portion of Adjust tracker URLs can fail to redirect, all incoming engagements and s2s requests aren't processed in full. Requests such as installs, sessions, and events sent by the Adjust SDK are not being processed but they will be buffered locally on each device and replayed in full once our services are back online.
We sincerely apologize for the disruption and inconvenience caused.
Posted May 23, 2025 - 10:21 UTC
This incident affected: Engagement Redirect Endpoint, SDK Endpoint, and Server to Server Endpoint.